PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelAvrunda tid upp eller nerAvrunda tid upp eller ner
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-11-13 20:21
 
 Ändrad av Nalle  på 2020-11-14 17:16:17

Kan någon hjälpa mig med följande problem.

Har en tid i A1 vill runda upp till hela kvartar om tiden är mer än 9 min över t, annars ner till närmaste kvart.

ex. 17:09 skall bli 17:15, 17:08  skall bli 17:00

 

Nytt inlägg
 2020-11-16 08:24
 

Hej hej

=AVRUNDA(A2*(24*60/15);0)/(24*60/15), denna avrunda dock enligt normala avrundningsregler och inte dina specialkrav, dvs brytpunkten ligger vid 7 minuter, 30 sekunder. Funktionen nedan hanterar Dina krav, men endast den kvarten som du givit ett exempel på, dvs övriga kvartar kommer att hanteras felaktigt. 

=VÄNSTER(TEXT(F5;"TT:MM");3)&OM((HÖGER(TEXT(F5;"TT:MM");2)+1-1)>8;15;"00")

Önskar du en heltäckande funtion som avrundar enligt dina önskemål så får du återkomma med minut angivelser även för de resterande kvartarna. 

MVh

Christian

 

Nytt inlägg
 2020-11-16 12:27
 

 Kan man inte använda Mavrunda på något smart sätt? (Mavrunda avrundar till en viss multipel, t.ex 15 minuter). Om man drar ifrån 1 munut före så borde det bli rätt. Typ:

=MAVRUNDA(MINUT(A1)-1;15)

Fast det blir konstigt vid Timmbyten så man måste nog kolla på hela tidsvärdet

=MAVRUNDA(A1-TIDVÄRDE("00:01");TIDVÄRDE("00:15"))

eller

=MAVRUNDA(A1-1/(24*60);15/(24*60))

Eller, om man bygger om Christians första formel llite grand

=AVRUNDA((A1-1/(24*60))*(24*60/15);0)/(24*60/15)

Nytt inlägg
 2020-11-16 22:02
 

 Hej, och tack för hjälpen, var lite otydlig med att samma vilkor skall gälla för alla kvartar.

Har fått det att fungera nu.

Nytt inlägg
 2020-11-16 22:02
 

 Hej, och tack för hjälpen, var lite otydlig med att samma vilkor skall gälla för alla kvartar.

Har fått det att fungera nu.

Nytt inlägg
 2020-11-16 22:03
 

 Hej, och tack för hjälpen, var lite otydlig med att samma vilkor skall gälla för alla kvartar.

Har fått det att fungera nu.

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelAvrunda tid upp eller nerAvrunda tid upp eller ner

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter