PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerVBAVBAExcel räcker inte till längre..Excel räcker inte till längre..
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2018-02-16 05:46
 

 Hej! 

Jag sitter med en uppgift där jag inte hittar någon bra lösning i vanliga excel utan blev rekommenderad att söka svaret här istället.

Det jag efterfrågar är:

"G2" ska först kontrollera vilken bokstav som står i "H2", antingen A (räkna arbetsdagar), K (räkna kalenderdagar), eller M (räkna hela månader). Därefter ska den kontrollera om där finns något slutdatum ifyllt i "D2", finns inget slutdatum ska det räknas kontinuerligt från "C2" mot dagens datum, annars ska den räkna mellan startdatum "C2" och slutdatum "D2"

"C2" innehåller ett startdatum, "D2" innehåller ett slutdatum (om ett slutdatum finns), "G2" ska innegålla formeln och "H2" ska innehålla en bokstav(A,K,M)

Har som sagt ingen kunskap alls i VBA och egentligen bara "basic" kunskaper i Excel.

Tacksam för all hjälp jag kan få.

Mvh Christoffer

Nytt inlägg
 2018-02-16 06:14
 

 Vad är det som inte fungerar med det sista lösningsförslag i din tråd i Excel delen?

Nästlade eller stackade viłkor är nästan enklare i Excel direkt.

VBA passar bäst för repeterade uppgifter eller väldigt udda formler.

Nytt inlägg
 2018-02-16 06:40
 

Jag får inte hela formeln till att fungera i en och samma cell.

kan säkert vara ja som gör fel.

Nytt inlägg
 2018-02-16 12:35
 
 Ändrad av anonymous  på 2018-02-16 13:43:24

Dubbelkolla så att forumet inte har klitsrat in mellanslag eller linande (kolla framför allt före det första = tecknet). Om delformlerna stämmer så borde det här ge rätt svar:

=OM(H2="A";NETTOARBETSDAGAR(C2;OM(D2="";IDAG();D2));OM(H2="K";OM(D2="";IDAG();D2)-C2;OM(H2="M";AVRUNDA.UPPÅT((OM(D2="";IDAG();D2)-C2)/30;0))))

Om du får ut datum eller andra konstigheter kan du testa att ställa dig i cellen och trycka Ctrl + 0  (en nolla inte ett o)

 

Om du absolut vill anväda VBA så kan du klistra in formeln med hjälp av det.

1. Kopiera raden/raderna nedanför

Range("G2").FormulaR1C1 = "=IF(RC[1]=""A"",NETWORKDAYS(RC[-4],IF(RC[-3]="""",TODAY(),RC[-3])),IF(RC[1]=""K"",IF(RC[-3]="""",TODAY(),RC[-3])-RC[-4],IF(RC[1]=""M"",ROUNDUP((IF(RC[-3]="""",TODAY(),RC[-3])-RC[-4])/30,0))))"

Ställ dig i ditt excelblad och Tryck på:

[ALT]+[F11]

[Ctrl]+G

[Ctrl]+V

[enter]

[Alt]+[F4]

Nu borde du ha en korrekt formel i G2

 

PS: om du vill använda Datedif för månaden så blir formeln någonting i stil med:

=OM(H2="A";NETTOARBETSDAGAR(C2;OM(D2="";IDAG();D2));OM(H2="K";OM(D2="";IDAG();D2)-C2;OM(H2="M";1+DATEDIF(C2;OM(D2="";IDAG();D2);"m"))))

 

 

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerVBAVBAExcel räcker inte till längre..Excel räcker inte till längre..

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter