PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerVBAVBAÖkande värde i celler?Ökande värde i celler?
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-03-10 09:41
 

 Hej!

Skulle behöva er hjälp med hur jag kan lägga till ett värde en stor mängd celler, detta värde skall öka med 1 och startposition är cell B12 som då skall ha värdet 1

Det är 2 värden på varje rad med 12 raders mällanrum (kolumn B och E)

Resultatet skall då vara enl. nedan och köras till rad 9600

B12 =1, E12 =2, B24 =3, E24 =4, B36 =5, E36 =6

 

Tack på förhand!

//Daniel

Nytt inlägg
 2020-03-10 10:05
 
Hej hej

Behöver du av någon anlending kod för detta så går det. Det går dock att lösa med en formel:

Lägg in denna i cell B2 och dra ner till rad 9600. Modifiera därefter formel och lägg den sedan i cell E2 och dra nedåt.
=OM(REST(RAD(A2);12)=0;SUMMA($B$1:B1)+1;"")

Mvh
Christian
Nytt inlägg
 2020-03-10 11:42
 

 Hej Christian, tack!

Men om jag skulle vilja köra denna funktion via macro, hur skulle koden då se ut?

 

/Daniel

Nytt inlägg
 2020-03-12 11:27
 
Hej hej

Nedan kod behöver du modifiera bladnamnet i, annars ska den fungera rakt av.
/c

Option Explicit

Sub increasenumber()

Dim bArr(1 To 9600, 1 To 1) As Variant
Dim eArr(1 To 9600, 1 To 1) As Variant
Dim i As Long
Dim iCount As Long: iCount = 0

For i = 1 To UBound(bArr)

If i Mod 12 = 0 Then
iCount = iCount + 1
bArr(i, 1) = iCount
iCount = iCount + 1
eArr(i, 1) = iCount
End If
Next i

Dim rngOutB As Range
Set rngOutB = Sheets("blad1").Range("b1:b9600")
Dim rngOutE As Range
Set rngOutE = Sheets("blad1").Range("e1:e9600")

rngOutB = bArr
rngOutE = eArr

End Sub
Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerVBAVBAÖkande värde i celler?Ökande värde i celler?

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter