PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelLeta värde baserat på flera kriterierLeta värde baserat på flera kriterier
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2021-02-18 07:43
 

 Hej,

Jag jobbar med ett ganska stort sortiment och med olika priser på olika prislistor. Jag har därför skapat en fil för att visa sortimentet strukturerat, men jag kan inte hitta en lösning där säljarna kan välja en prislista från en dropdown och få fram priset för den aktuella artikeln på prislistan.

 

Alla artiklar och prislistor är strukturerade i en egen flik enligt nedan (det är inte den fliken säljarna använder, därav problemet). 

Jag vill kunna välja en produkt och en prislista i en annan flik (enligt C1:D2) och att värdet sen kollas upp i listan enligt C6:H25 och returnerar ett värde som i D3.

 

Hur gör jag? LETARAD funkar ju inte med flera kriterier och returnerar värde i en förutbestämd kolumn. SUMMA.OMF funkar med flera kriterier men returnerar också ett summerat värde från en förutbestämd kolumn och jag kan inte veta den förutbestämda kolumnen eftersom den bestäms av ett av kriterierna. 

 

Hur gör jag!? :) 

 

Nytt inlägg
 2021-02-18 09:52
 

 Hej Göran

Så det du behöver göra är att leta mot både produkter och namnet på prislistan. Detta går visserligen även med Letarad, men det är bättre att använda index/passa.

=INDEX(C6:H25;PASSA(D1;C6:C25;0);PASSA(D2;D5:H5;0))

Med Letarad/passa

=LETARAD(D1;C6:F8;PASSA(D2;C5:F5;0);FALSKT)

Mvh

Christian

Nytt inlägg
 2021-02-18 09:52
Accepterat svar 

 Hej Göran

Så det du behöver göra är att leta mot både produkter och namnet på prislistan. Detta går visserligen även med Letarad, men det är bättre att använda index/passa.

=INDEX(C6:H25;PASSA(D1;C6:C25;0);PASSA(D2;D5:H5;0))

Med Letarad/passa

=LETARAD(D1;C6:F8;PASSA(D2;C5:F5;0);FALSKT)

Mvh

Christian

Nytt inlägg
 2021-02-23 12:22
 
 Ändrad av goran  på 2021-02-23 13:41:40

Med lite anpassning verkar det som att jag har fått det att fungera.

 

Stort tack för hjälpen!

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelLeta värde baserat på flera kriterierLeta värde baserat på flera kriterier

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter