PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelIF-formel i flera nivåerIF-formel i flera nivåer
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2018-05-16 11:17
 

Hej hej

Jag har ett litet problem. Jag har ett tips där formeln tidigare har undersökt om en användare har satt rätt mål och rätt tecken (1X2) och därefter gett poäng. Om vi t.ex. har en tävlare som heter Vargen så ser formeln i dokumentet som heter Rättning ut så här

=IF(Rättning!I3=Vargen!I3;2;0)+IF(Rättning!K3=Vargen!K3;2;0)+IF(Rättning!L3=Vargen!L3;1;0)

Alltså om han har rätt mål på hemmalaget får han två poäng, dettsamma med bortalaget och har han rätt tecken får han 1p.

Jag vill på något sätt modifiera detta (utan att behöva lägga in massa extra celler) så att poängsättningen istället blir

1p för mål, 1p för mål, 2p för tecken och 1 bonuspoäng om man har rätt mål på båda och tecknet rätt.

Jag försökte mig på  =IF(Rättning!I3:L3=Vargen!I3:L3;5;IF(Rättning!K3=Vargen!K3;2;0)+IF(Rättning!L3=Vargen!L3;1;0)

alltså om allting stämmer får han 5p och annars så undersöker den via IF-formler hur många poäng han får.

Kan jag göra detta på något sätt utan att lägga till massa extra dolda formler?

Nytt inlägg
 2018-05-16 17:15
 

Kolla om alla tre (4:a inkl kolumn j) är rätt

=PRODUKTSUMMA((vargen!I3:L3=rättning!I3:L3)*1)=4

=OCH(rättning!I3=vargen!I3;vargen!K3=rättning!K3;vargen!L3=rättning!L3)

Då blir din andra formel något i stil med:

=OM(PRODUKTSUMMA((vargen!I3:L3=rättning!I3:L3)*1)=4;5;OM(rättning!I3=vargen!I3;1;0)+OM(rättning!K3=vargen!K3;1;0)+OM(rättning!L3=vargen!L3;2;0))

=OM(OCH(rättning!I3=vargen!I3;vargen!K3=rättning!K3;vargen!L3=rättning!L3);5;OM(rättning!I3=vargen!I3;1;0)+OM(rättning!K3=vargen!K3;1;0)+OM(rättning!L3=vargen!L3;2;0))

 

 

Ett smidigare alternativ, Din första formel-ish, men översätt 4 till 5

=VÄLJ(OM(rättning!I3=vargen!I3;1;0)+OM(rättning!K3=vargen!K3;1;0)+OM(rättning!L3=vargen!L3;2;0);1;2;3;5)

VÄLJ()=CHOOSE()

Kortare men kanske svårbegripligt. 

=VÄLJ((rättning!I3=vargen!I3)*1+(rättning!K3=vargen!K3)*1+(rättning!L3=vargen!L3)*2;1;2;3;5)

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelIF-formel i flera nivåerIF-formel i flera nivåer

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter