PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelTa bort dubbletter mellan två kolumner Ta bort dubbletter mellan två kolumner
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-01-14 15:12
 

Hej! Är inte jättebevandrad i Excel utan mer självlärd. Sitter nu och hackar lite på jobbet för att bygga en urvalsmodell i flera olika steg. Hur jag än trixar och fixar, googlar och håller på får jag inte ordning på ett steg i denna hantering och hoppas nu att någon av er har idé som kan ta mig vidare. 

Jag har data i två kolumner A och B.
Urvalet i A kommer från en korskörning mellan ursprungsdata och uppgifter i B. Det har gett mig ett antal dubbletter i datan som finns både i A och B.
I nästa steg skulle jag vilja att dessa dubbletter togs bort ur kolumn B.

Datan ligger på eget blad där data i A är dubblett med data i B. Nu skulle jag vilja radera dubbletten från kolumn B så jag får en ren lista utan dubblettvärden i kolumn B. Jag får inte excel att förstå att dubbletten är linjär och ta bort värdet. Det närmaste jag kommit är när jag kör villkorsstyrd formatering som då markerar upp dubbletterna linjärt. Men det hjälper mig inte då jag i sådana fall får ta bort alla manuellt, vilket inte är ett alternativ.

Exempel på hur det ser ut mellan kolumn A och B efter korskörning.
A  B
1  1
    3
    4
2  2
 

Nytt inlägg
 2020-01-14 16:09
 

Är inte helt säker på vad du vill.

Men om du har nyaste excel kan du testa den här formeln någonstans och se om det gör det du vill:

=FILTER(A:B;A:A<>B:B)

Då skapas en ny tabell där rad 1 och 4:a är borttagna (hela raden tas bort, både A och B)

 

Om du bara vill ta bort värdet i B kolumnen men behålla värdet i A så kan du skapa en ny tabell bredvid. 

I C1 skriver du 

=A1

och i D1

=OM(A1<>B1;B1;"")

Kopiera ner så långt det behövs

Nytt inlägg
 2020-01-15 08:55
 
Nu vet jag inte hur många rader det rör sig om men om du kör din egen variant med markering via villkorsstyrdformatering och sedan sorterar listan på cellfärg. Då kommer du att få alla dubbletter i en följd och hyfsat snabbt kan du ta bort dem.
Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelTa bort dubbletter mellan två kolumner Ta bort dubbletter mellan två kolumner

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter