PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelDefinera pris matris?Definera pris matris?
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-10-12 13:32
 

 Jobbar med excel som jag anser är ganska kunni, men kört fast.

Vill skapa en matris där pris pengar skall kunna delas ut enligt matrisen:

Antal:     1:an    2:an    3:an    4:an
6-10       0,7       0,3       0         0
11-15     0,55     0,3      0,15      0
16-20     0,45     0,28   0,15      0,12

Där jag anger enligt mallen, som finns på en hemsida ser formeln ut: =OM(C8<10;(D27*0,6)*0,7)/3 där cellen C8 är antal deltagare i klass A, C9 i klass B, C10 i klass C, D27 är prispotten som skall delas ut, och det finns 3 klasser (A, B och C) så delas det med 3.

När jag skriver det på en rad så fungerar det, men när jag går vidare i matrisen tar det stopp där.

Formeln ser ut så här (i detta fall 1:an som ska få):

=OM(C8<20;(D27*0,6)*0,45)/3
=OM(C8<15;(D27*0,6)*0,55)/3
=OM(C8<10;(D27*0,6)*0,7)/3

Och 2:an enligt formeln:
=OM(C8<20;(D27*0,6)*0,28)/3
=OM(C8<15;(D27*0,6)*0,3)/3
=OM(C8<10;(D27*0,6)*0,3)/3

3:an:
=OM(C8<20;(D27*0,6)*0,15)/3
=OM(C8<15;(D27*0,6)*0,15)/3
=OM(C8<10;(D27*0,6)*0)/3,"Inga pengar"
 

Hoppas ni förstår? Fråga om det är något?

Nytt inlägg
 2020-10-12 15:58
 

Jag vet inte om jag förstår vad du frågr om. Men här har du lite exempel att leka med:

 

Om placeringen står i A1 så kan du slå upp matrisvärde med hjälp av "hårdkodad" passa/index: 

=INDEX({0,7\0,55\0,45;0,3\0,3\0,28;0\0,15\0,15;0\0\0,12};A1;PASSA(C8;{6;10;15};1))

eller så här om du tycker att det är mer logiskt att läsa radvis:

=INDEX({0,7\0,3\0\0;0,55\0,3\0,15\0;0,45\0,28\0,15\0,12};PASSA(C8;{6;10;15};1);A1)

 

se kan du ju faktiskt förenkla din formel lite.

=OM(C8<10;(D27*0,6)*0,7)/3 

eftersom 0,6/3=0,2

så kan den lika gärna skrivas:

=OM(C8<10;(D27)*0,7)*0,2

eller

D27*0,2*slåuppvärdet

slå ihop till:

=$D$27*0,2*INDEX({0,7\0,3\0\0;0,55\0,3\0,15\0;0,45\0,28\0,15\0,12};PASSA($C$8;{6;10;15};1);$A$1)

sen får du ädnra D27, C8 och A1 efter behov

Nytt inlägg
 2020-10-13 09:12
 

 Hmm, nästan rätt! Men inte 100% rätt.

Anta att man har en tävling, och startavgiften ligger på 950 kr och 475 och det kom in 10 och 2 st så summan blir då 10450 kr vilket det anges i cellen D27, och man även har angett antal deltagarna i cellen C8, då när det vara uträkning för 1:an (10450*0,6)*0,55 och blir då 2448 kr, 2:an får 1881 kr (0,55 byts till 0,3). 3:an får då 940 kr(här byter man till 0,15).

Vill poängtera att 0,6, 0,55, 0,3 och 0,15 är i % omvandlat till decimal (i detta vallet 60%, 55%, 30% och 15%).

Nytt inlägg
 2020-10-13 09:39
 

 Hej hej

Om du ändrar lite i din matris så blir den mycket lättare att göra beräkningar mot.

Ändra så att du endast behåller det lägre intervallet under antal, dvs 6,11,16

Därefter trycker du ctrl+t när du står i din matris, så att du får en tabell.

Därefter kan du hämta 1:ans resultat med formeln: 

=D27*0,6*LETARAD(C8;Tabell1;2;SANT)/3.

Denna kommer att hitta rätt koefficient beroende på antal deltagare. Vet dock inte varför du multiplicerar med 0,6, är det för att 40% ska till "huset"?

2:an hittar du med =D27*0,6*LETARAD(C8;Tabell1;3;SANT)/3. Notera att ända skillnaden är att en tvåa blivit utbytt med en trea. Du kommer därför kunna lösa 3:an och fyran själv :). 

Mvh

Christian

 

Nytt inlägg
 2020-10-20 12:19
 
 Ändrad av DragonII  på 2020-10-20 11:21:36

Hej igen!

Tack för tipset! Fick fungera ganska bra.

När man skriver in i vissa siffrorna, som t.ex:

Inkomster: (bestäms från inbjudansbrevet)
Avgift per person 500 kr
Avgift per lag   200 kr

Och skriver antal deltagarna i respektive klasser:

Anmälda splare i respektive klass *:          
               
A 10 st *= Klasserna kan lätt bytas till ålderklasserna.
B 10 st  T.ex A = Herrveteran, B= Damer osv.  
C 10 st          
D 0 st D-klassen används inte oftast. Sätt 0 om det inte
      blir något aktivitet.      
Antal klasser: 3            


Då räknas det både totalt deltagarna och lag samt summan:

Lag  Herrar 5 st Skall 2-mannaslag vara mixat, använd bara herrar.
Lag Damer 3 st          
Totalt anmälda personer:   30 st      
Totalt lag:     8 st      
               
Intäkter totalt: 15000 kr varav för lag: 1600    
        Herrar 1000    
        Damer 600    

Efter att ha dragit av för hyran och avrode:

Utgifter:      
Banhyra   7000 kr
Avrode   500 kr
  Totalt: 7500 kr
       
Återstående belopp: 7500 kr

Där återstående belopp ska användas till vinster i respesktive klass (10% går redan avkortat till arrangören):

Priser till vinnarna:        
           
Klass 1 2 3 4 5
A 1575 675 0 0 0
B 1575 675 0 0 0
C 1575 675 0 0 0
D #SAKNAS! #SAKNAS! #SAKNAS! #SAKNAS! #SAKNAS!

Då har man använt denna formeln:
=$D$29*0,9*INDEX({1\0\0\0\0;0,7\0,3\0\0\0;0,55\0,3\0,15\0\0;0,45\0,28\0,15\0,12\0;0,43\0,25\0,14\0,1\0,08};PASSA($C$8;{1;6;11;16;21};1);$C$33)/C13

D29 är placering, 1:a, 2:a, 3:e,4:e och 5:e, C8, C9, C10 och C11 är antal anmälda deltagarna. C33 är potten som skall fördelas. C13 är antal klasser.
Då det är 0 på klass D och ger värdet #Saknas!, där vill jag att det ska stå 0.

Hur gör jag det? Vill också kunna justera så det går jämt upp/ner på jämna hundra eller tio krona.
Och hur kan jag låsa så det inte går att justera/ändra på formelerna?

Mvh

 

Nytt inlägg
 2020-10-21 10:02
 

Hej hej

Givet att er monsterformel faktiskt fungerar så:

=omfel($D$29*0,9*INDEX({1\0\0\0\0;0,7\0,3\0\0\0;0,55\0,3\0,15\0\0;0,45\0,28\0,15\0,12\0;0,43\0,25\0,14\0,1\0,08};PASSA($C$8;{1;6;11;16;21};1);$C$33)/C13;0)

Denna ersätter samtliga typer av fel med värdet 0. 

Att däremot avrunda priserna till närmsta 100, 10, toch där summan ska gå jämt upp, är i många fall mattematiskt omöjligt, även fast det i exemplet faktiskt skulle gå. För detta får du nog bita i det sura och göra en manuell korrigering i en tabell jämte.

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelDefinera pris matris?Definera pris matris?

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter