PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelSenaste förekomsten av ett visst kriterie baserat på datumSenaste förekomsten av ett visst kriterie baserat på datum
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-12-19 15:37
 

Hej!

Jag bygger ett kalkylblad för spårning av träningspass under en månad för ett antal användare. 

Pass nr. Datum Aktivitet Typ (Kondition/Styrka) Brända kalorier Styrkepoäng Utförare
1 12/13/2020 Kupolen Styrka - 24 Louise
2 12/13/2020 Kupolen Styrka - 24 Svante
3 12/14/2020 Kupolen ben Styrka - 23 Mathias
4 12/14/2020 Kupolen cykel Kondition 300 - Mathias
5 12/14/2020 Kupolen cykel Kondition 190 - Svante
6 2020/12/15 Hemma cykel Kondition 275 - Louise
7 2020/12/16 Kupolen ben Styrka - 18 Mathias
8 2020/12/16 Kupolen CT Kondition 160 - Mathias
9 2020-12-17 Promenad Kondition 338 - Mathias
10 2020-12-19 Promenad Kondition 331 - Louise
11 2020-12-19 Promenad Kondition 331 - Svante

Jag vill hitta en funktion för att hitta antalet dagar sedan senaste träningspass med inritkning kondition respektive styrka enligt nedan. Jag förstår hur jag kan hitta antalet dagar sedan ett specifikt träningspass men inte hur jag ska hitta senaste förekomsten i kolumnen Kondition/Styrka respektive Utförare.

 Senaste träningspass | Kondition | Styrka

Användare 1                        1              2

Användare 2                        4              3

Användare 3                       2              5

Någon som kan ge mig ett uppslag?

Tack på förhand!

/Mathias

Nytt inlägg
 2020-12-21 13:32
Accepterat svar 

 Hej. Om du har en någorlunda ny excel kan du använda MAXIFS (borde heta MAX.OMF, men av någon anledning översattes den aldrig)

Då hittar du det högsta värdet (dvs senaste datumet) som uppfyller vissa villkor

=IDAG()-MAXIFS(B2:B12;G2:G12;"Louise";D2:D12;"Kondition")

Eller så här om du har tabell

=IDAG()-MAXIFS(Tabell1[Datum];Tabell1[Utförare];"Louise";Tabell1[Typ (Kondition/Styrka)];"Kondition")

 

Eftersom vissa kombinationer inte kommer att finnas  (T.ex Louise:Styrka) så kan det vara smart att hantera det på något sätt. Eftersom svaret på sökningen blir 0 så kan du utnytja att 1/0 är oändligt och ger ett felmeddelande (samtidigt som 1/1/x  faktistkt ger svaret X) 

Så, om ditt första användarnamn står i cell R2 och tränsingsformen i S1:T1 så kan du peta in den här formeln i S2 och kopiera ner en kolumn till höger+ så många rader dert behövs

=OMFEL(IDAG()-1/(1/(MAXIFS(Tabell1[Datum];Tabell1[Utförare];$R2;Tabell1[Typ (Kondition/Styrka)];S$1)));"")

obs att excelformler och forum inte trivs så bra tillsammans. Om det inte funkar så kan du skriva in varje del för sig och sedan klistra ihop

PS: byt till samma visningsformat i datumkolumnen. Nu ser det väldigt förvirrande ut. 

Nytt inlägg
 2020-12-21 13:34
 

 Hej. Om du har en någorlunda ny excel kan du använda MAXIFS (borde heta MAX.OMF, men av någon anledning översattes den aldrig)

Då hittar du det högsta värdet (dvs senaste datumet) som uppfyller vissa villkor

=IDAG()-MAXIFS(B2:B12;G2:G12;"Louise";D2:D12;"Kondition")

Eller så här om du har tabell

=IDAG()-MAXIFS(Tabell1[Datum];Tabell1[Utförare];"Louise";Tabell1[Typ (Kondition/Styrka)];"Kondition")

 

Eftersom vissa kombinationer inte kommer att finnas  (T.ex Louise:Styrka) så kan det vara smart att hantera det på något sätt. Eftersom svaret på sökningen blir 0 så kan du utnytja att 1/0 är oändligt och ger ett felmeddelande (samtidigt som 1/1/x  faktistkt ger svaret X) 

Så, om ditt första användarnamn står i cell R2 och tränsingsformen i S1:T1 så kan du peta in den här formeln i S2 och kopiera ner en kolumn till höger+ så många rader dert behövs

=OMFEL(IDAG()-1/(1/(MAXIFS(Tabell1[Datum];Tabell1[Utförare];$R2;Tabell1[Typ (Kondition/Styrka)];S$1)));"")

obs att excelformler och forum inte trivs så bra tillsammans. Om det inte funkar så kan du skriva in varje del för sig och sedan klistra ihop

PS: byt till samma visningsformat i datumkolumnen. Nu ser det väldigt förvirrande ut. 

1 Rapporter 
Nytt inlägg
 2020-12-22 18:32
 

 Jättetack! Ska genast införa detta och justera datumformat!

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelSenaste förekomsten av ett visst kriterie baserat på datumSenaste förekomsten av ett visst kriterie baserat på datum

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter