PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelMedel på första fyra värdena i en kolumnMedel på första fyra värdena i en kolumn
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2021-01-06 09:58
 

Hej,

Jag har en kolumn med värden i några celler medan andra celler är tomma. Jag skulle vilja räkna ut medelvärdet på de fyra första (uppifrån och ner) värdena (exkludera de tomma cellerna) i kolumnen.  

Hur gör jag detta?

Stort tack på förhand!

Nytt inlägg
 2021-01-07 09:49
 

Hej. Så här får du fram en lista på bara de ifyllda (siffror) cellerna

 =FILTER(A:A;ÄRTAL(A:A))

Endast de 4:a första

=INDEX(FILTER(A:A;ÄRTAL(A:A));SEKVENS(4))

Och medel av det

=MEDEL(INDEX(FILTER(A:A;ÄRTAL(A:A));SEKVENS(4)))

 

Om du har en äldre excel utan filter och sekvens så kan du hitta den 4:e raden med hjälp av:

=MÄNGD(15;6;RAD(A:A)/ÄRTAL(A:A);4)

Mängd är en "hållare" för andra funktioner med lite extra trix.

Det första argumentet "15" betyder att du vill använda Minsta
Det andra argumentet "6" betyder att du vill hoppa över rader som ger felmeddelanden
Det tredje argumentet "RAD(A:A)/ÄRTAL(A:A)" ger radnumret om det står ett tal i cellen. Annars blir det fel (division med 0)
Det fjärde argumentet "4" säger att det är det 4:e minsta radnumret du vill ha (av de ifyllda raderna)

Antag att det 4:e värdet t.ex står på rad7. Då kan du använda "förskjutning" för att hämta A1:A7

=FÖRSKJUTNING(A1;0;0;MÄNGD(15;6;RAD(A:A)/ÄRTAL(A:A);4))

och så medel på det

=MEDEL(FÖRSKJUTNING(A1;0;0;MÄNGD(15;6;RAD(A:A)/ÄRTAL(A:A);4)))

 

Nytt inlägg
 2021-01-07 12:31
 

 Stort tack!

Jag vill bara säga att det här forumet och dess användare är fantastiskt! Till mycket stor hjälp! Tack!

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelMedel på första fyra värdena i en kolumnMedel på första fyra värdena i en kolumn

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter