PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelSumma.omf synliga raderSumma.omf synliga rader
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2020-07-03 07:34
 

 Hej,

Jag har en tabell där jag räknar summan för alla rader i en kolumn med ett villkor om att räkna bort de rader som det i en annan kolumn finns texten "avslutad". Exempel nedan:

=(SUMMA(Säkerheter[Belopp]))-(SUMMA.OMF(Säkerheter[Belopp];Säkerheter[Status];"Avslutad"))

Nu försökte jag även lägga till en delsumma så jag kan få samma funktion när jag väljer att filtrera bort vissa rader, problemet är att summa.omf räknar med alla rader även de som filtrerats bort för tillfället. Exempel:

=DELSUMMA(9;M1:M666)-(SUMMA.OMF(Säkerheter[Belopp];Säkerheter[Status];"Avslutad"))

Finns det något smidigt sätt att lösa detta med delsumma eller ett villkor för summa.omf där det endast räknas med synliga rader?

Tack på förhand!

Nytt inlägg
 2020-07-09 12:48
 

 Din försa formel summerar egentligen bara de rader som inte är = "Avslutad"

så den kan skrivas som:

=SUMMA.OMF(Säkerheter[belopp];Säkerheter[status];"<>Avslutad")

Eller

=SUMMA((Säkerheter[status]<>"Avslutad")*Säkerheter[belopp])

Nu kan man ju tro att den sista formeln går att köra med delsumma iställen:

=DELSUMMA(9;(Säkerheter[status]<>"Avslutad")*Säkerheter[belopp])

Men, nej. Det funkar inte med den "moderna" Delsumma heller (MÄNGD). Så du får göra en krånglig lösning. BEskrivs här:

https://exceljet.net/formula/count-visible-rows-only-with-criteria

Och det blir ju en en sät liten formel...

=PRODUKTSUMMA((Säkerheter[status]<>"avslutad")*Säkerheter[belopp]*(DELSUMMA(103;FÖRSKJUTNING(Säkerheter[[#Rubriker];[belopp]];RAD(Säkerheter[belopp])-MIN(RAD(Säkerheter[belopp]));0))))

där den sista delen 

*(DELSUMMA(103;FÖRSKJUTNING(Säkerheter[[#Rubriker];[belopp]];RAD(Säkerheter[belopp])-MIN(RAD(Säkerheter[belopp]));0)))

Enbart använs för att se om en rad är filtrerad eller ej. Enkelt och självklart.  Nja...?

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelSumma.omf synliga raderSumma.omf synliga rader

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter