PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelHjälp med matchning i tre kolumnerHjälp med matchning i tre kolumner
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2019-12-02 18:54
 

 Hej, jag vill sortera i denna tabell så att jag tillexempel får en färg när ett värde återfinns i alla tre kolumner, alternativt att den sorterar så att alla värden som finns i tre kolumner hamnar på samma rad. Stort tack på förhand!

 

SH NH G
551929 524058 388603
520395 388603 613539
390401 353748 250718
510719 868158 315960
597906 551929 311910
554097 390989 282368
593079 488270 240994
995365 488171 202234
Nytt inlägg
 2019-12-03 09:32
 
Hej hej

Med villkorsstyrd formatering så kan du se till att alla värden som återfinns tre gånger lyser upp med en färg. Jag har dock ingen metod för att lysa upp olika träffar med olika färger, för detta bör vba krävas.

Markera hela ditt dataområde, inkludera inte rubrikerna.. Därefter väljer du på: Startfliken -> Villkorsstyrdformatering ->ny regel - >Bestäm vilka celler som ska användas genom formel.

Har du data med unika värden i varje kolumn så kan du skriva:
=ANTAL.OM(Område;värde)>2

Exempel:
=ANTAL.OM($C$4:$E$11;C4)>2
var noga med att se till att dina absoluta/relativa referenser(dollartecknena) blir enligt mitt exempel, annars kommer det inte fungera.

Har du inte unika värden i varje kolumn så kan du använda nedan lösning:
=OCH(ANTAL.OM(Område;värde)>0;ANTAL.OM(Område;värde)>0;ANTAL.OM(Område;värde)>0)
Exempel:
=OCH(ANTAL.OM($C$4:$C$11;C4)>0;ANTAL.OM($D$4:$D$11;C4)>0;ANTAL.OM($E$4:$E$11;C4)>0)

Ps. jag noterade att du i ditt exempel inte hade några förekomster av samma värde i varje kolumn.. se gärna till att du har det innan du testar så du vet att den villkorsstyrda formateringen fungerar.

Lycka till
Christian
Nytt inlägg
 2019-12-03 10:08
 
 Ändrad av anonymous  på 2019-12-03 10:13:07

ED

Jag missade att C hade svarat under tiden. Låter mitt svar stå kvar.  Eftersom vi i princip föreslår samma saker så måste de vara bra :-)

/ED

 

Färgning

Två värden är enkelt.

Markera dina kolumner och gå till:

Start->vilkorrsyrd formatering->Regler för cellmarkering->Dubblettvärden

Men det går inte att utöka till 3, så det har du ingen nytta av. Du får göra en egen formel. 

Jag antar att dina data står i kolumn A:C

Markera dina data-kolumner (börja från vänster så att cell A1 har en lite annorlunda färg) och gå till:

Start->vilkorrsyrd formatering->Ny Regel ->Bestäm.vilka ... formel:

=(ANTAL.OM($A:$C;A1)>=3)

[Formatera], fliken fyllning

Nu bör alla trippletter markeras

OBS! Formeln kollar bara om värdet finns tre gånger. Värdet kan alltså finnas 3 gånger i samma kolumn. Vill du vara helt säker på att Värdet finns i alla tre kolumner så får du krångla till formeln T.ex så här:

=((ANTAL.OM($A:$A;A1)>0)+(ANTAL.OM($B:$B;A1)>0)+(ANTAL.OM($C:$C;A1)>0)=3)

 

Sortering

Om du vill lägga dina färgade triplettter högst upp så måste du sortera varje kolumn för sig. Det enklaste är att lägga en tom kolumn mellan varje datakolumn. Då blir varje kolumn ett eget dataområde och kan sorteras separat.

Sortera och filtrera->anpassad sortering->Sortera efter: Cellfärg (i ordna väljer du din färg så att den hamnar överst)
Klicka på knappen [Lägg till en nivå] och välj "sortera efter": cellvärden  (då ökar chansen att värdena hamnar på samma rad)

Upprepa för alla tre kolumner

 

Om du inte vill ha tommma kolumner så kan du markera en kolumn i taget ->Sortera och filtrera->anpassad sortering->Fortsätt med aktuell markering->Sortera efter: Cellfärg (i ordna väljer du din färg så att den hamnar överst)
Klicka på [Lägg till en nivå] och välj "sortera efter": cellvärden

Upprepa för alla tre kolumner

 

Nytt inlägg
 2019-12-04 18:26
 

 Stort tack för hjälpen! Skall prova så snart jag kommer åt.

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelHjälp med matchning i tre kolumnerHjälp med matchning i tre kolumner

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter