PNG32 PNG32 PNG32 PNG32
PNG32
Forum Excel, VBA, VSTO, Exceltips, Excelhj�lp PNG32 drivs av Excelspecialisten    Logga in     English
PNG32
PNG32 PNG32
PNG32

Logga in

PNG32

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

Du är inte inloggad. Logga in eller registrera dig för att skriva inlägg eller svara på inlägg.

För frågor om forumet, kontakta oss på webmaster@excelforum.se

PNG32 PNG32
PNG32 PNG32
PNG32

Excelforum

PNG32

 
ForumForumDiskussionerDiskussionerExcelExcelSummera värden i kolumn med villkorSummera värden i kolumn med villkor
Föregående Föregående
 
Nästa Nästa
Nytt inlägg
 2021-02-01 15:19
 
 Ändrad av Per-Axel  på 2021-02-01 16:59:48
Hej. Jag har kämpat ett tag nu med olika lösningar för mitt excellblad men nu ger jag snart upp..
 
I mitt excel har jag ett antal kolumner var på de viktigaste är A, B och C. A  innehåller olika resursnamn, B innehåller datum och C innehåller tider.
 
B-kolumnen med datum har jag ett filter på och det resulterar i att vissa rader ej syns vilket är helt rätt. Det jag vill är att kolumn C ska summeras om den hittar t.ex. ett resursnamn i A och det gör den om jag använder SUMMA.OM ellerSUMMA.OMF men resultatet blir fel eftersom den även tar med de dolda raderna som jag inte vill. Nu har jag googlat ihjäl mig och prövat alla möjliga olika formler men inte hittat rätt så nu hoppas jag på hjälp här.
 
Tack på förhand
 
Per-Axel
Nytt inlägg
 2021-02-01 16:07
 
 Ändrad av Christian  på 2021-02-01 17:09:24

 Hej hej

Pröva funktionen mängd, den har möjligheten att ignorera dolda rader, fel m.m. den här dock inte antal.om, men detta går att komma runt med att skriva en jämförelse där du ska peka ut ditt område. Den kan se ut ungefär såhär: =mängd(3;4;(--(A:A="en resurs"))*C:C). Slå in den med ctrl shift enter. Se till att välja rätt funktion, kan inte i huvudet vilka siffror som gör vad.

Mvh

Christian 

Nytt inlägg
 2021-02-01 17:04
 

 Hej 

Det såg onekligen bra ut ditt förslag. Vet inte riktigt var jag gör fel men jag får hela tiden #VÄRDFEL som resultat. Har provat med några olika funktioner men med samma resultat. Sen är jag nog inte riktigt med på noterna när du säger "Slå in den med ctrl shift enter" (sorry för min okunnighet)...

Nytt inlägg
 2021-02-02 10:20
 
 Ändrad av anonymous  på 2021-02-02 12:02:14

Jag tror faktiskt inte att MÄNGD funkar.

Mängd klarar av villkor om man använder en summeringsfunktion som har en matris som svar (dvs använder det sista villkoret). Det går t.ex inte att hitta min-värdet. Men om man frågar efter det n mista så funkar det (t.ex en 1:a för det minsta...).

Det här hittar det minsta värdet i C när A=en resurs

=MÄNGD(15;7;(C:C)/(A:A="en resurs");1) 

medan det här inte gör det:

=MÄNGD(5;7;(C:C)/(A:A="en resurs"))

(eller, funkar och funkar. Det är ju meningen att den skall ta bort filtrerade...)

MÄNGD (Funktionen MÄNGD) - Office-support (microsoft.com)

 

 

Det enklaste är att skapa en hjälpkolumn med en delsumma på varje rad som räknar antal synliga. Dvs någonting i stil med:

=DELSUMMA(2;C2)

Då har du en variabel som är 1/0 beroende på om raden är synlig eller ej och du kan använda den i din SUMMA.OMF

 

Om du hatar hjälpkolumner kan du göra den "virtuelt" och summera med Produktsumma

https://exceljet.net/formula/count-vi...

Men det blir ganska oaptitligt:

=PRODUKTSUMMA((A2:A1000="en resurs")*(DELSUMMA(109;FÖRSKJUTNING(C2;RAD(C2:C1000)-RAD(C2);0))))

I alla fall jämfört med att använda hjälpkolumnen

=SUMMA.OMF(Blad1!$C$2:$C$1000;Blad1!$D$2:$D$1000;1;Blad1!$A$2:$A$1000;"en resurs")

Nytt inlägg
 2021-02-05 13:26
 

 Som jag tolkar det har du tid i formatet TT:MM i kolumn C.

Om kolumn A innehåller en text så vill du att Kolumn C på samma rad ska summeras med alla andra rader där kolumn A innehåller en text?

Jag föreslår att du lägger till en hjälpkolumn i D.

Rad 1: =OM(A1="";0;TIMME(C1)+(MINUT(C1)/60))

Rad 2: =OM(A2="";0;TIMME(C2)+(MINUT(C2)/60))

osv.

Om Resursnamn är helt blank returnerar det 0, om det är någon typ av data i resursnamnet så räknar det om TT:MM till timmar som sifferform.

 

Sedan väljer du en valfri cell där du vill redovisa summan, där skriver du =SUMMA(D1:D10), men med de celler du faktiskt använt.

 

Nytt inlägg
 2021-02-10 08:42
 

 Nu är kämpandet över. Tack för all hjälp och era förslag. Det som bäst löste mitt problem blev @anonymous förslag.

 

=PRODUKTSUMMA((A2:A1000="en resurs")*(DELSUMMA(109;FÖRSKJUTNING(C2;RAD(C2:C1000)-RAD(C2);0))))

 

Återigen Tack för hjälpen!!

Per-Axel

Föregående Föregående
 
Nästa Nästa
ForumForumDiskussionerDiskussionerExcelExcelSummera värden i kolumn med villkorSummera värden i kolumn med villkor

PNG32 PNG32
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Excelforum drivs av Excelspecialisten som bedriver utbildning i Excel och VBA, tillhandahåller support och hjälp med Excel, utvecklar program i Excel. Är ni i behov av en konsult inom Excel, VBA eller VSTO, eller söker en excelkurs, kontakta oss.
Copyright 2013 ExcelSpecialisten XLS AB   Användarvillkor  Personliga uppgifter